From Mageia wiki
Jump to: navigation, search


Not all BuildRequires need to be in the .spec file.
If a package is already available on the Build System by default, there is no need to add it to the .spec.

On June 22nd 2013, the following packages were present:

Notepad.png
Please note!

That will have changed by now, some packages will have a higher version, others may have been dropped or added. You can find the current packages by

  • submitting a package without any BuildRequires
  • going to pkgsubmit.mageia.org and, after it is uploaded
  • clicking on "uploaded" on the same line as the package name and then on "rpm_qa.*.log"

The null test package can be used to do this.

If you do so, then please update this list + the date it was generated
alsa-utils-1.0.27.1-1.mga4
aumix-text-2.9.1-3.mga3
autoconf-2.69-2.mga3
automake-1.13.4-1.mga4
basesystem-minimal-2-15.mga3
bash-4.2-45.1.mga4
binutils-2.23.51.0.8-3.mga3
bzip2-1.0.6-3.mga3
chkconfig-1.3.60-1.mga3
common-licenses-1.1-3.mga3
coreutils-8.21-2.mga4
cpio-2.11-5.mga3
cracklib-dicts-2.8.22-3.mga3
cronie-1.4.10-3.mga3
crontabs-1.10-17.mga3
curl-7.30.0-1.mga4
dash-static-0.5.7-3.mga3
dbus-1.6.12-1.mga4
desktop-file-utils-0.21-2.mga3
diffutils-3.3-1.mga4
dmsetup-1.02.77-3.mga3
dwz-0.10-1.mga4
e2fsprogs-1.42.7-1.mga3
elfutils-0.155-2.mga3
etcskel-1.63-29.mga3
ethtool-3.9-1.mga4
file-5.14-1.mga4
filesystem-2.1.9-20.mga3
findutils-4.5.11-1.mga4
gawk-4.1.0-1.mga4
gcc-4.7.2-7.mga3
gcc-c++-4.7.2-7.mga3
gcc-cpp-4.7.2-7.mga3
genhdlist2-6.5-4.mga4
gettext-0.18.2.1-1.mga4
gettext-base-0.18.2.1-1.mga4
glibc-2.17-7.mga4
glibc-devel-2.17-7.mga4
gpg-pubkey-80420f66-4d4fe123
grep-2.14-6.mga3
gzip-1.5-3.mga3
ifmetric-0.3-12.mga3
ifplugd-0.28-15.mga3
info-install-4.13a-10.mga3
initscripts-9.41-14.mga3
iproute2-3.7.0-2.mga3
iputils-20121221-2.mga3
kbd-1.15.3-4.mga3
kernel-userspace-headers-3.9.7-1.mga4
kmod-12-2.mga3
krb5-1.11.3-1.mga4
less-458-1.mga4
libacl1-2.2.51-6.mga3
libalsa-data-1.0.27.1-1.mga4
libalsa2-1.0.27.1-1.mga4
libattr1-2.4.47-1.mga4
libaudit1-2.2.3-1.mga3
libblkid1-2.23.1-2.mga4
libbzip2_1-1.0.6-3.mga3
libcap-ng0-0.7.3-2.mga3
libcap2-2.22-3.mga3
libcloog0-0.15.11-2.mga3
libcrack2-2.8.22-3.mga3
libcroco0.6_3-0.6.8-3.mga3
libcryptsetup4-1.5.1-2.mga3
libcurl4-7.30.0-1.mga4
libdaemon0-0.14-5.mga3
libdb5.3-5.3.21-2.mga3
libdbnss5.3-5.3.21-2.mga3
libdbus1_3-1.6.12-1.mga4
libdevmapper-event1.02-1.02.77-3.mga3
libdevmapper1.02-1.02.77-3.mga3
libelfutils1-0.155-2.mga3
libexpat1-2.1.0-4.mga3
libext2fs2-1.42.7-1.mga3
libffi6-3.0.13-1.mga4
libgcc1-4.7.2-7.mga3
libgcrypt11-1.5.2-1.mga4
libgdbm4-1.10-3.mga3
libgettextmisc-0.18.2.1-1.mga4
libglib2.0_0-2.37.2-1.mga4
libgmp10-5.1.1-1.mga3
libgmpxx4-5.1.1-1.mga3
libgnutls-ssl27-3.2.1-1.mga4
libgnutls28-3.2.1-1.mga4
libgomp1-4.7.2-7.mga3
libgpg-error-common-1.10-3.mga3
libgpg-error0-1.10-3.mga3
libhogweed2-2.7.1-1.mga4
libidn11-1.26-2.mga3
libintl8-0.18.2.1-1.mga4
libkmod2-12-2.mga3
libkrb53-1.11.3-1.mga4
libldap2.4_2-2.4.33-7.mga3
liblockdev1-1.0.4-0.120111007git.5.mga3
liblua5.1-5.1.5-2.mga3
liblzma5-5.1.2-0.alpha.3.mga3
libmagic1-5.14-1.mga4
libmicrohttpd10-0.9.23-2.mga3
libmount1-2.23.1-2.mga4
libmpc3-1.0.1-2.mga3
libmpfr4-3.1.2-1.mga3
libncurses5-5.9-10.mga3
libncursesw5-5.9-10.mga3
libnettle4-2.7.1-1.mga4
libnspr4-4.9.6-1.mga3
libnss3-3.14.3-1.mga3
libopenssl-engines1.0.0-1.0.1e-2.mga4
libopenssl1.0.0-1.0.1e-2.mga4
libp11-kit0-0.18.2-1.mga4
libpam0-1.1.6-5.mga3
libpam_userpass1-1.0.2-7.mga3
libpci3-3.2.0-1.mga4
libpcre1-8.32-9.mga3
libpopt0-1.16-4.mga3
libppl9-0.11.2-5.mga3
libppl_c4-0.11.2-5.mga3
libpth20-2.0.7-10.mga3
libpwl5-0.11.2-5.mga3
libpython2.7-2.7.5-1.mga4
libreadline6-6.2-8.mga4
librpm3-4.11.0.1-1.mga3
librpmbuild3-4.11.0.1-1.mga3
librpmsign3-4.11.0.1-1.mga3
libsasl2-2.1.25-12.mga3
libsigsegv2-2.10-2.mga3
libsqlite3_0-3.7.17-1.mga4
libssh2_1-1.4.3-2.mga3
libstdc++-devel-4.7.2-7.mga3
libstdc++6-4.7.2-7.mga3
libsystemd-daemon0-204-2.mga4
libsystemd-id128_0-204-2.mga4
libsystemd-journal0-204-2.mga4
libsystemd-login0-204-2.mga4
libtasn1_6-3.3-1.mga4
libtcb0-1.1-2.mga3
libtermcap2-2.0.8-53.mga3
libtool-base-2.4.2-10.mga3
libudev1-204-2.mga4
libunistring0-0.9.3-9.mga3
libuser-0.59-1.mga3
libuser1-0.59-1.mga3
libutempter0-0.5.5-13.mga3
libuuid1-2.23.1-2.mga4
libwrap0-7.6-43.mga3
libxml2_2-2.9.1-1.mga4
libzlib1-1.2.7-7.mga3
lockdev-1.0.4-0.120111007git.5.mga3
logrotate-3.8.5-1.mga4
lsb-release-2.0-40.mga4
m4-1.4.16-3.mga3
mageia-release-Default-4-0.1.mga4
mageia-release-common-4-0.1.mga4
make-3.82-6.mga3
makedev-4.4-16.mga3
meta-task-3-43.mga4
mingetty-1.08-8.mga3
multiarch-utils-1.0.13-2.mga3
ncurses-5.9-10.mga3
net-tools-1.60-36.mga3
nss-3.14.3-1.mga3
nss-myhostname-0.3-2.mga3
nss_tcb-1.1-2.mga3
openldap-2.4.33-7.mga3
p11-kit-0.18.2-1.mga4
pam-1.1.6-5.mga3
pam_tcb-1.1-2.mga3
passwd-0.78-3.mga3
patch-2.7.1-2.mga3
pciutils-3.2.0-1.mga4
perl-5.18.0-5.mga4
perl-Config-IniFiles-2.820.0-1.mga4
perl-File-Slurp-9999.190.0-2.mga3
perl-File-Sync-0.110.0-5.mga4
perl-Filesys-Df-0.920.0-10.mga4
perl-JSON-2.590.0-1.mga4
perl-List-MoreUtils-0.330.0-5.mga4
perl-Locale-gettext-1.50.0-9.mga4
perl-MDK-Common-1.2.29-3.mga4
perl-MDV-Distribconf-4.02-8.mga4
perl-MDV-Packdrakeng-1.13-11.mga4
perl-Module-ScanDeps-1.100.0-2.mga3
perl-Time-ZoneInfo-0.300.0-3.mga3
perl-URPM-4.27-2.mga4
perl-XML-LibXML-2.1.800-1.mga4
perl-XML-NamespaceSupport-1.110.0-3.mga3
perl-XML-SAX-0.990.0-3.mga3
perl-XML-SAX-Base-1.80.0-2.mga3
perl-YAML-0.840.0-2.mga3
perl-YAML-Tiny-1.510.0-2.mga3
perl-base-5.18.0-5.mga4
pkgconfig-0.28-1.mga4
popt-data-1.16-4.mga3
prcsys-0.0.3-8.mga3
procps-3.2.8-6.2.mga3
psmisc-22.20-2.mga3
python-2.7.5-1.mga4
python-magic-5.14-1.mga4
python-pkg-resources-0.6.45-1.mga4
python-rpm-4.11.0.1-1.mga3
resolvconf-1.68-4.mga3
rmt-0.4b44-2.mga3
rootcerts-20121229.00-4.mga3
rootfiles-11.0-9.mga3
rpm-4.11.0.1-1.mga3
rpm-build-4.11.0.1-1.mga3
rpm-helper-0.24.11-3.mga3
rpm-mageia-setup-1.172-1.mga4
rpm-mageia-setup-build-1.172-1.mga4
rpmlint-1.4-5.mga4
rpmlint-mageia-policy-0.2.26-3.mga3
run-parts-4.2-4.mga3
sash-3.7-13.mga3
sed-4.2.2-2.mga3
setup-2.7.20-6.mga4
shadow-utils-4.1.5.1-5.mga3
sound-scripts-0.62-15.mga3
spec-helper-0.31.8-2.mga3
sudo-1.8.6p8-1.mga4
systemd-204-2.mga4
systemd-units-204-2.mga4
sysvinit-legacy-tools-2.87-22.mga4
tar-1.26-4.mga3
tcb-1.1-2.mga3
termcap-11.0.1-21.mga3
time-1.7-39.mga3
timezone-2013c-1.mga3
unzip-6.0-6.mga3
update-alternatives-1.9.0-10.mga3
urpmi-7.27.3-1.mga4
utempter-0.5.5-13.mga3
util-linux-2.23.1-2.mga4
which-2.20-8.mga3
xz-5.1.2-0.alpha.3.mga3