From Mageia wiki
Revision as of 07:18, 22 November 2021 by Cmoifp (talk | contribs) (Removing the hidden comment, the language template is there for that.)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search


Drakconf multiflag.png
Other languages

Deutsch ; English  ; Español ; Français ; Português(Portugal)


Notes

This page is a companion to the Release Notes.

Old Errata version for Mageia 8 RC is here.

Entries below prepended with "FIXED", have a released update. So if you experience a problem marked fixed, try to do a full update. Some issues may need logout/login or reboot. Some are installation or upgrade issues. Note it may take a day for a released update to reach your mirror.

Only significant issues with packages contained in the ISOs are listed here, plus wider coverage related to upgrading. - We have a lot of additional software in repositories.

A non-listed issue you see may be fixed if you do a full update.

Also see Release Notes Known issues and Bug reporting sections.

Note that we will be updating issues from the bugtracker, i.e FOR_ERRATA8, IN_ERRATA8, FOR_RELEASENOTES8 as they are decided.

Boot

See Graphics.

Live images

mga#28768 The draklive manual embedded on Live ISOs lacks one page, thus the menu entry "Updates" doesn't work. The full manual is available online.

Installer images

Crash at end of install

mga#27838 Some computers have buggy firmwares, causing writes to EFI NVRAM to fail at end of Mageia installation.

Workaround: When configuring the bootloader at end of the install: Select rEFInd instead of GRUB, check "Install in /EFI/BOOT", uncheck the option to store to NVRAM (New for Mageia 8)

NetInstaller

  • On some UEFI machines the NetInstaller ISO boots with a Grub error message: error: ../../grub-core/video/readers/png.c:595 invalid filter value And shows Grub2 menu using text mode instead of graphic. Functionality is not affected; it is just a cosmetic quirk. mga#28225
  • If the source of the Mageia installation is in a USB device formatted with exFAT filesystem you may have to unplug and replug the USB device to get access to the partition. Comment#23 in mga#28371

32-bit installer must be on DVD to work as repository

After system install, the Classic Installer ISOs can be utilized as a repository, to install software from without using internet.

The 64 bit ISO works for this both when placed on DVD and on a USB stick. The 32 bit ISO does not work as a repository from USB.

Graphics

AMD/ATI

Described problems are most visible on Live media or system installed with Classic ISO without update repos enabled. Some updates have improved the situation, some resume fixes coming in kernel, and most importantly see the explanation and workaround below.

  • Boot problem with some Radeon HD GPU. Example: mga#28154
  • Resuming problem, despite booting OK. Example: mga#28863
  • Legacy VGA not working yet (upstream problem), so for instance if you have dual screen with one on VGA, the VGA connected one don't work. Example: mga#28817

Explanation: For AMD graphic cards based on Southern Islands family (Tahiti, Pitcairn, Oland, Verde, Hainan) and Sea Islands family (Kaveri, Bonaire, Hawaii, Kabini, Mullins) we are now defaulting to the newer amdgpu driver instead of the older less developing radeon. We appreciate feedback if it fails on your hardware, see mga# above.

Workaround for both cases above: use the older radeon driver (like Mageia 7 default) by adding the following on kernel command line:

For Southern Island cards: radeon.si_support=1 amdgpu.si_support=0

For Sea Islands cards: radeon.cik_support=1 amdgpu.cik_support=0

Nvidia

Nvidia has neglected to fix security issues in their 340 series driver, so we had to drop it from official repos. See Release Notes.

Desktops

mga#23929 - The folder Desktop in $HOME is not translated with Plasma or MATE only DE installation

mga#25877 - Netapplet/Mgaapplet/nm_applet with Cinammon or Xfce: When the applet is in a panel at the bottom of the screen, it's pop-up appears only as a black bar at the bottom of the screen. Workaround here.

mga#27601 - The boot hangs with a black screen and the mouse cursor still mobile. This is due to a change of hostname during SDDM start, set by avahi or networkmanager when the hostname is localhost. The workaround is to set the hostname to a personal value, for example with the command hostnamectl set-hostname myhost.local.

FIXED mga#28378 - SDDM greeter does not remember previous session. Manual fix if upgrade have been made before the fix: In /etc/sddm.conf in the line RememberLastSession=false change false to true.

Plasma

Wayland session with Nvidia's nvidia-current proprietary drivers is available by making sure that "nokmsboot" is removed and "nouveau.modeset=0" is passed to Kernel command line. Note mga#27296 - Plasma Wayland session broken, and mga#28365 - Control Center does not start in Plasma Wayland - Temporary fix: as normal user, first issue xhost +si:localuser:root

Compiz desktop effects is no longer compatible with Plasma. If you use it in Plasma on Mageia 7 then disable it in Mageia Control Center : Hardware -> Configure 3D Desktop effects - before upgrade, and if you don't want Compiz for another desktop environment, uninstall it. After install/upgrade of Mageia, you find desktop effects at System Settings (slider icon in main launch menu) Workspace -> Workspace Behavior -> Desktop Effects.

Dolphin right click extension kde-rootactions-servicemenu is removed as it is unmaintained upstream and have issues.

mga#27147 - Multi-users successive logins, plasmashell no longer runs log on to whatever user after going into sleep.

mga#27183 - Screenshot not launched by PrintScr key - Default Mageia spectacle integration settings missing in plasma5 systemsettings - On some occasions after upgrade. Manual fix: Launch Spectacle, press Configure -> Shortcuts. Select each entry under "Spectacle" and change the setting to "Default", and confirm in the popup asking to reassign. OK the main dialogue. If PrtScn key still does not make Spectacle show, then rename ~/.local/share/kglobalaccel/org.kde.spectacle.desktop (Maybe add "X" to the end). It may contain custom settings, you can delete it, see upstream bug.

FIXED by Mageia 8 updates: startplasma-x11 spawns zombie processes - mga#27362 (many packages), mga#28824 (qtbase), mga#28859 (systemd)

mga#28095 - Avatar Change not working on Classic Install Mageia 8 but does work on Live. Manual fix here.

mga#28287 - new plasma workspace does not allow unlocking of widgets when upgrading from older version. Plasma5 desktop and panel widgets cannot be locked/unlocked in Plasma version 5.18 onwards. This means that any such widgets locked before the upgrade cannot be unlocked after. So before upgrading, be sure to UNlock all such widgets. If you do find locked widgets after upgrading, this will unlock them: $ qdbus org.kde.plasmashell /PlasmaShell evaluateScript "lockCorona(false)"

mga#28299 - GTK apps complain (in log) about missing window_decorations.css. - Manual fix here.

mga#28342 - No shadows on GTK menus in GTK apps under Plasma. - When the theme "Breeze" is set in System Settings : Application Style -> Configure GNOME/GTK Application Style, there is no shadow in GTK right-click and GTK menus. Workaround: Set it to "Adwaita" (which is default).

mga#28623 - Alt+F2 fail to launch the Run command dialogue. - Manual fix: In System Settings : Shortcuts -> System Services -> KRunner *) , unfold section KRunner *), and under "Default Shortcuts" checkmark "Alt+F2". If it asks for confirmation, say yes. Apply, close System Settings and try if it works. If it does not, repeat the procedure. If still not, see bug. *) KRunner may be translated to something corresponding to "Run program".

mga#28827 - KDE Connect can not browse into devices. Explanation: If Mageia was installed using Classic Installer ISO without online repositories enabled, the suggested package sshfs-fuse will not be installed. Manual fix: Install sshfs-fuse.

GNOME

Wayland: By default, GNOME uses the Wayland display server. Wayland is still not fully mature, and may not work well on some hardware. Normally GNOME will automatically fall back to using the X.org display server if Wayland fails to start, but in some cases, this fails to happen. If the GNOME desktop fails to launch after completing the initial language and locale selection, or if you experience display problems, you can try forcing GNOME to use the X.org display server by adding nowayland to the boot options in the initial boot menu (press e to edit the boot options).

Network: By default, the NetworkManager service is enabled in place of the old network management services. You can use the drop-down menu accessible from the top right corner of the GNOME desktop to perform any necessary network configuration. For wired connections, the network is usually configured automatically, and you don't need to do anything. For wireless networks, you will usually need to select an access point and, if it is password-protected, enter the password. Network configuration via the MCC/drakconnect should also work in most cases.

Xfce

mga#24134 - After login the display may show black and white bands or interesting effects for a couple of seconds.

mga#27795 - In Xfce, net_applet (internet connection icon) does not react to changes in connection status properly

LXQt

mga#28360 The compositor for transparency, generally used with Openbox, used to be compton. This one is deprecated and replaced by picom. If you upgrade from Mageia 7, the configuration file ~/.config/compton.conf can have some incompatible parameters which need to be edited. - Or simply delete that file. Unfortunately we have no Picom configuration tool yet.

Picom looks for configuration in the following order: ~/.config/picom.conf, ~/.config/compton.conf, /etc/xdg/picom.conf. That means a customized picom.conf can reside in ~/.config/ for a personal configuration or in /etc/xdg/ for a system wide configuration. So for customisation per user copy /etc/xdg/picom.conf to ~/.config/ and edit it there.

If you instead want to use compton-conf configuration similar to Mageia 7, install the compton-conf rpm and then copy /usr/share/compton-conf/compton.conf.example and edit it like below.

How to edit compton settings to picom compatible: Rename ~/.config/compton.conf to picom.conf, and in it disable the lines starting with: no_dnd_shadow, no_dock_shadow, clear shadow, menu_opacity, alpha_step, paint-on-overlay by prepending them with a #. Make the line starting with vsync read vsync = false; , and replace the whole line starting with glx-swap-method with use-damage = true; .

To start Picom: Mageia -> Accessories -> picom. To have Picom automatically start at login: LXQt configuration center -> LXQt settings -> Session Settings -> Autostart -> Add Name: Picom, Command: picom.

Some help, if needed: 1) Launch picom from a terminal and see the output, exit with Ctrl-C. 2) /etc/xdg/picom.conf have comments.

---

FIXED for new users: mga#28407 Default terminal in pcmanfm shall be qterminal, not xterm. Manual fix for existing users in already made upgrade or install: Use pcmanfm-qt preferences GUI. (Our general policy is to not force user preferences.)

Software

Firefox ESR

FIXED by an update mga#29064 - A packaging issue caused various problems with a few sites, solving i.e. mga#27374, mga#28359.

Note that still a few sites choose to not accept Firefox ESR (even upstream version), and demand non ESR version. You can help informing the problematic sites that Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

As workaround you can try using an user agent switcher to spoof a non-ESR Firefox. Alternatively you can install the Firefox non-ESR version for example by using Flatpak.

Flatpak

Plasma Discover and Gnome-software prefer Flatpak over Mageia RPM packages.

Mageia Welcome

mga#28328 - Steam cannot be installed with the one-click button proposed with Mageia Welcome if 32bits repositories are not enabled, as it is the case by default. - 32 bit repositories should be enabled to complete the installation.

FIXED by Mageia 8 update mga#28806 - MageiaWelcome MCC tab display incorrectly for Chinese and Japanese.

Phone USB connection

Android, MTP: mga#28216. The libusb packages have been updated to include backported upstream fixes to improve Android phones USB connectivity. As you know there is a vast variety of Android devices. - Where there are still problems, try another method to connect, i.e over wifi using kdeconnect-kde (works for more than Plasma, and provide more than file transfer) or filesyncing serverless using i.e Syncthing or a cloud service. For more information visit our wiki page File transfer with Android devices.

iPhone: mga#28669 The packages ifuse and usbmuxd are missing by default. Manual fix: install them.

Various software

mga#9683 - LibreOffice langpacks are not installed for Chinese and Portugese-Brazil. Manual fix: install them.

mga#28963 - LibreOffice package libreoffice-emailmerge and the task package libreoffice are not installed when installing from the classical ISO images. Manual fix: install libreoffice.

mga#22425 - Draksnapshot fail to launch.

mga#27340 - FreeCAD GUI fails to display. Manual fix: delete ~/.mozila/plugins/mozplugger0.so left over from a Mageia 7 to 8 upgrade.

mga#28097 - xviewer seg fault; also, not in application menus

FIXED by an update mga#28363 - VLC crashes when opening an MKV file when the video codec is AV1

mga#28683 - OGMRip fail to launch. Problem is also seen in other distros, and upstream seem stale.

Wine miss a few dependencies for 32 bit libs. (Thus also PlayOnLinux.) Manual fix and also other tips here. mga#28814, mga#28840

Security

Boot of system with cyphered partitions

mga#19800 - CVE-2016-4484 Failed tries to enter the password of a cyphered partition with LUKS end with a shell.

People who want to secure their system have to:

  • add a BIOS password
  • add a grub password
  • add “rd.shell=0” to the kernel command line

Miscellaneous

Hibernation

mga#28528 - Resuming from hibernation instead start fresh. Upstream bug. Manual fix: 1) Verify that there is no line containing "add_dracutmodules" in output of cat /etc/dracut.conf.d/51-mageia-resume.conf . 2) Add the missing line by as root executing echo 'add_dracutmodules+=" resume "' >> /etc/dracut.conf.d/51-mageia-resume.conf and then generate new initrd: dracut -fv . After dracut finish, resume shall work. If not, you have other problem - please consult our forum.

Networking

Downloading software

For a few users, the default download method intermittently fails. Workaround: Start drakrpm-edit-media which is Mageia Control Center section Software Management -> Configure media sources for install and update. In Options -> Global options set "Download program to use" to "wget". mga#24362

Printing

Printing in gtk webkit applications

mga#28758 - Upstream bug in sandboxing may make printing from gtp applications such as Evolution not work. Workaround, upstream links and more info see bug first post.

Printer duplicate - not a bug

You may see your printer shown twice. That is because you are shown all available printers on both the local CUPS server (localhost) and all connected CUPS servers. So if you share a printer to the network, which is the default, it will be shown as two on the sharing computer. This behaviour is not specific to Mageia.

Workaround: Tell CUPS to not share the printer queue job on local network if you do not need to use it from another computer. See Mageia Control Center Section Hardware > Printing menu Server -> Settings.

Shell / Terminals

"bracketed paste" mode affecting copy&paste

By default readline 8.1 enabled the so-called "bracketed paste" mode, which in turn is effective for example in the bash shell. This means that if anything is pasted in your terminal, the pasted text will be enclosed by invisible escape characters \e[200~ and \e[201~
The visible effect is that this swaps the background and foreground highlighting colors for the pasted text, and one also needs to either press any key or click with the mouse to be able to execute the pasted text.
For more information about this, refer to bracketed paste mode.

This can be disabled for bash by adding bind 'set enable-bracketed-paste off' to ~/.bashrc and sourcing ~/.bashrc or by running a new bash shell.

Supposedly it should also be possible to disable this by adding set enable-bracketed-paste off to ~/.inputrc but this does not seem to have any effect.

Upgrade issues

Be sure to follow one of the procedures in Release Notes. Avoid screen saver interfering! mga#25251

Upgrade issues Tracker bug.

If upgrade failed

If you can not boot to a usable state, boot on Classical ISO and perform an upgrade. Remember to not format any partition. Important: you must enable any update repos that has been active during previous upgrade or previous release. Also note that Classic does not use nonfree drivers, you may need wired ethernet. If that can not be accomplished, try instead the Nonfree version of Network Installer ISO - it has more wifi support. For more details see Available installation media.

If all upgrade attempts fail, the fallback is to do a fresh install, possibly keeping (not formatting) /home.

No upgrade offered by the applet

News: enabled 2021-04-04

The applet in system tray that tells when normal updates exist for your system, will also tell when you can upgrade to a new Mageia release.

As usual, we delay enabling this message in order to solve issues found by early installers and upgraders. So just wait, or upgrade per methods described in the Release Notes.

Upgrade using DNF

Extra kernel flavour installed - DNF uses a different method to select kernel flavour than Mageia installer. This may result in that a system that was using the desktop kernel, after upgrade have both desktop and server installed, and server used. Manual fix: select at boot the desktop kernel, then uninstall server kernel. mga#28272

PHP7 dropped

Mageia 8 have no PHP7. This may cause problem if you have software that is not compatible with PHP8.

Examples:

Workaround: You may be able to compile PHP7 yourself, see our forum.

Removed packages

Generally, see at end of Release Notes.

VirtualBox

There is no longer a VirtualBox 32 bit host.

Unused packages

After upgrade, you may find that there are a lot of unused packages installed. (Reported as orphans, or you can not directly see what they are installed for.)

Be careful - they may actually be needed:

The user may have third party software that requires the modules in those lib packages or requires old packages that are not lib packages. The third party software may be compiled from source, or manually copied binary files - not installed using rpm, so the package manager do not know. Also, if you alter between using DNF and urpmi, the orphan tracking does not work for either of them.

As long as the old packages do not interfere with new packages, we have chosen to let users choose which old packages they do not need and uninstall them manually if they wish to. (If you do, please keep a log of what you uninstall.)

You will also see that the updater have not only let old packages remain, but also installed corresponding upgrade Mageia versions of them - see it as a service.

Even on a new install, there will be multiple versions or alternatives of some packages installed as being suggested by different packages. These packages are not required, just suggested or recommended, so are orphans from the moment they are installed.

For more info see Removing packages.

Various upgrade issues

Optimus / Mageia Prime may need you to run mageia-prime-uninstall followed by mageia-prime-install. See this bug comment and our Mageia Prime wiki page.

mga#27880 - x2go server. For now, Manual fix in mga#27880#c9

FIXED by Mageia 8 update mga#28007 - llvm-11.0 mga8 packages conflicts with mga7 llvm-devel packages when updating MGA7 to MGA8

mga#28018 - Google Earth Pro - See our wiki page Google Earth on how to install it for Mageia 8 (and Cauldron).

mga#28352 - KiCAD fails to enable HW acceleration. Workaround: Use flatpak.

FIXED by Mageia 8 update mga#28419 - Boomaga virtual printer: The mga7 version remains installed after upgrading - along with the new mga8 package. Manual Fix: Uninstall the mga7 package. If it refuse to uninstall: as root rpm -e --noscripts boomaga-3.0.0-1.mga7 - or leave it - it works with both installed anyway... If you find Boomaga printer have disappeared from your printer choices, again configure it in Mageia Control Center Hardware -> Set up the Printer.... Be aware that leaving both the mga7 and mga8 versions of the Boomaga packages installed will cause the same problem with any future Boomaga updates and Mageia upgrades.

FIXED by Mageia 8 update mga#28479 - batik package conflicts from upgrading Mageia 7 to 8

FIXED by Mageia 8 update mga#28481 - npm has higher release on Mageia 7 than on Mageia 8 causing upgrade problems.

FIXED by Mageia 8 update mga#28485 - mythtv upgrade MGA7->MGA8 fails on file conflicts

FIXED by Mageia 8 update mga#28503 - php-json belongs to Mageia 7 and breaks PHP in Mageia 8 - php-json is now bundled = there is no extension anymore. Manual fix for them who already updated: Remove the lingering php-json package.

FIXED by Mageia 8 update mga#28522 - File conflicts with opencv-devel cause cascading errors during upgrade from Mageia 7 to 8

mga#28550 - If UID is 500, the $PATH variable doesn't contain /usr/games, thus games can't be launched. This affect systems originally installed with Mageia version 6 or earlier and upgraded since, or a manually set UID < 1000. This can not easily be fixed in a safe way for every case. See bug for ideas how to fix and ask on our forum if you need further help.

FIXED by Mageia 8 update mga#28636 - python3-gdal-3.1.3-7.mga8 conflicts with file from package lib(64)gdal-devel-2.4.3-1.1.mga7

FIXED by Mageia 8 update mga#28679 - Upgrade from 7 to 8 (DNF/CLI) fails on package M8 CairoSVG conflict with M7 cairosvg

mga#28724 - mgaapplet upgrade: asks where to first download all packages but dont respect neither download location nor "all first".

FIXED by Mageia 8 update mga#28743 - LibreOffice help does not work.

mga#28914 - Some Gimp plugins are missing, which were in Mageia 7.


Samba

FIXED by Mageia 7 update mga#28042 - While upgrading to MGA8: ERROR:'script' failed for samba-client-4.10.18-1.1mga7.x86_64. In most cases you can neglect that error message.