From Mageia wiki
Jump to: navigation, search
Drakconf multiflag.png
Autres langues

Deutsch ; English ; Español ; Français ; Türkçe ;

Cette page est une traduction des Errata de Mageia 5 en anglais. Certains problèmes découverts récemment ne sont peut-être pas encore répertoriés ni traduits.


Contents

Introduction

Même si nous avons mis beaucoup d'énergie et de temps à corriger des bogues, nous ne pouvons pas tous les résoudre à moins de retarder la sortie de la version pendant très longtemps. En fait, nous avons déjà retardé la publication, pour diverses raisons, dont la fin des travaux sur la prise en charge de l'UEFI.


La liste ci-dessous contient les questions que les contributeurs veulent mettre en évidence, pour diminuer les risques que les utilisateurs soient soudainement impactés par un ou plusieurs d'entre eux.


Cette liste est valide le jour de la sortie de Mageia 5. Si vous êtes en train de lire cette page plusieurs semaines ou plusieurs mois après la sortie, il y a une forte chance que les bogues aient été corrigés via une mise à jour.


Il est difficile de dresser la liste de chaque problème qui pourrait être encore valide.


Pour une liste complète de tous les bogues et les demandes d'amélioration qui ont été déposées pour l'installateur ou le processus de version, et qui ne sont pas encore résolus (mais confirmés), veuillez voir la liste complète des bogues ouverts du programme d'installation et de la version


Pour une liste complète de tous les bogues qui ont été déposés pour des paquetages, et qui ne sont pas encore résolus, voir tous les bogues Cauldron ouverts "MGA5TOO" (Cette liste doit être ajustée dès que version peut être réglé sur "5", sans retirer les bogues "MGA5TOO").

DVD d'installation classique

Mode UEFI ou BIOS (classique)

Notepad.png
À noter !
De nombreux ordinateurs disposent maintenant de l'UEFI, mais avec lesquels vous pouvez aussi utiliser le mode BIOS classique. Si l'ordinateur démarre dans le mode incorrect pour votre installation ou mise à niveau, l'installation ou la mise à niveau échoueront. Voir ci-dessous



Si l'écran d'amorçage présente les boutons F1, F2, etc. situés au bas de l'écran, comme ici http://doc.mageia.org/installer/4/en/content/images/dx-welcome.png, alors vous avez démarré en mode classique (BIOS).


Si l'écran d'amorçage n'a pas ces boutons, comme cet écran d'amorçage https://wiki.mageia.org/mw-en/images/5/57/KO-grub2-installer1.png, alors vous avez démarré en mode EFI.


Veuillez lire davantage ici Installation_sur_les_systèmes_avec_firmware_UEFI-fr#BIOS_ou_firmware_UEFI.

Live CD/DVD

Notepad.png
À noter !
Sur certains matériels (souvent anciens), les LiveCD/DVD peuvent prendre beaucoup de temps à charger, montrent un écran noir pendant un moment et/ou ont l'air d'attendre après un message d'erreur. Cependant, ayez de la patience : le Live continuera à charger dans presque tous les cas et fonctionnera bien


Sélection des options d'armorçage

  • En appuyant sur les touches F2-F6 pour modifier les options du noyau, cela change également la sélection de Amorcer à Installer (mga#5263).

Supprimez manuellement le mot "install" de la ligne d'options du noyau pour exécuter le mode live au lieu de l'installation, ou simplement changer la ligne à "Armocer" avec les touches fléchées.

  • L'option "Armorcer sur le disque dur" dans le menu de démarrage du média Live ne fonctionnera pas si le média Live est démarré dans un client Virtualbox ou s'il est déversé dans un périphérique flash USB (mga#16038).

ISO GNOME Live

  • Il existe plusieurs situations obscures où le processus de démarrage se termine avec un message "Oh non! Quelque chose a mal tourné". Il est plus probable lors d'un amorçage DVD plutôt qu'à partir de l'USB, et plus probable avec le choix 'Live' à partir du menu de démarrage qu'avec le choix 'Installer'. Si vous ne pouvez pas contourner ce problème, utilisez plutôt l'ISO Classique pour installer GNOME.
  • En raison d'une mauvaise configuration du thème GTK+2 dans les ISOs GNOME live, les applications GTK+2 y compris LibreOffice et Firefox peuvent apparaître avec la valeur par défaut en amont Raleigh ("blocky") au lieu du thème Adwaita qui est la valeur par défaut de GNOME. Ceci affecte les deux ISOs Live et systèmes installés avec le live ISOs, mais une mise à jour sera publiée rapidement après la sortie de Mageia 5 pour corriger ce problème sur les systèmes installés. L'alternative est de sélectionner le thème Adwaita pour applications GTK utilisant gnome-tweak-outil.

ISO KDE Live

Il y a pas de problème important connu à ce jour qui serait spécifique à l'ISO KDE Live.

Toutes les ISOs Live

Les ordinateurs avec des graphiques hybrides

Les ISOs Live peuvent échouer pour démarrer l'interface graphique (X) sur les ordinateurs portables qui ont à la fois un processeur graphique intégré et une carte graphique séparée. C'est le cas des ordinateurs portables utilisant la technologie NVIDIA Optimus, par exemple.


Vous pouvez essayer d'ajouter un paramètre d'amorçage spécial. Nous avons créé pour l'occasion : optimus, qui déclenche une " solution de contournement.
Remarque : dans l'ISO KDE Live, il est possible qu'elle démarre KDE dans une nouvelle activité vide, au lieu de la valeur par défaut. Bon, cela vaut mieux qu'un écran noir.

Vous pouvez également essayer une combinaison des paramètres du noyau rdblacklist= et xdriver=

  • Pour Intel et NVIDIA pour forcer l'utilisation du pilote Intel : rdblacklist=nouveau rdblacklist=nvidia xdriver=intel. Cela force l'utilisation du pilote Intel.
  • Si cela échoue malgré cela en mode UEFI, essayer de déactiver la gestion d’énergie : rdblacklist=nouveau rdblacklist=nvidia xdriver=intel nouveau.runpm=0

Cela semble uniquement requis par certains nouveaux ou rares chipsets, qui ne sont pas encore pleinement pris en charge par le pilote "nouveau". Voir mga#16245.

  • Si cela échoue (et ce n'est pas en mode UEFI, parce qu'il n'y a pas de pilote vesa en mode UEFI), vous pouvez essayer le pilote vesa : rdblacklist=nouveau rdblacklist=nvidia xdriver=vesa


Voir mga#15734.

Pour optimus, plus infos disponibles sur https://wiki.mageia.org/en/Mageia_5_Errata-fr#NVIDIA_Optimus

Problèmes d'installation

amorçage double avec Windows 7 (peut-être aussi avec 8 lorsqu'il est installé en mode BIOS classique)

Grub ne détecte pas Windows 7/8 sur certains systèmes

Voir mga#15375 A certaines occasions, Grub n'ajoute pas Windows au menu d'amorçage pendant l'installation.
Cette option peut être fixée après le démarrage de Mageia, par

  • Aller dans le CCM => Démarrage => "Configurer le démarrage du système"
  • Cliquez sur "Suivant"
  • sélectionner "Ajouter"
  • Choisissez " Autre OS (Windows)"
  • Sélectionner la bonne partition avec le chargeur de démarrage Windows (probablement /dev/sda1 ou /dev/sda2) dans la liste déroulante.

A moins que d'être sûr d'installer Mageia sur un ancien ordinateur avec BIOS, veuillez lire ceci en premier Mode UEFI ou BIOS/classique


installations UEFI

Parce qu'il y avait de nombreuses améliorations à un stade tardif du développement de Mageia 5, nous n'avons pas été en mesure de mettre à jour notre Manuel de l'installateur officiel. Pour obtenir des instructions sur la manière d'effectuer une installation UEFI, veuillez lire Installation_sur_les_systèmes_avec_firmware_UEFI-fr que nous maintenons à jour.

D'un point de vue général, la partition ESP (Partition Système EFI) doit être montée sur /boot/EFI. Si vous utilisez le partitionnement de disque personnalisé, cela devrait être pré-sélectionné dans la liste déroulante des points de montage; si vous ne le voyez pas, il suffit de le taper manuellement.

Pour les installations Live et Classique, la configuration du chargeur de démarrage et l'installation ultérieure du chargeur de démarrage peuvent prendre 10 minutes (chacun) pour terminer, montrant une fenêtre vide. Ne désespérez pas, cela a quelque chose à voir avec os-prober, et reste à corriger. Une grande majorité des testeurs n'a heureusement pas recontré ce problème.

Notepad.png
À noter !
Certains fournisseurs d'ordinateurs ont rendu impossible le démarrage votre Mageia tout juste installée. Nous ne pouvons pas résoudre cela, voir : Mageia_5_Errata-fr#le firmware EFI de certains fournisseurs est forcé à utiliser MS Windows par défaut


installations NON UEFI

Pas de problème important connu à ce jour.

Partitionnement en volume RAID

L'installation sur un nouveau système RAID 0 peut connaitre des problèmes si vous essayez de créer une 5e partition, mais elle fonctionne normalement avec un nombre moins élevé de partitions. Un contournement est que le programme d'installation classique peut heureusement travailler avec des partitions MS-Windows existantes dans une configuration RAID 0, permettant un redimensionnement manuel de la partition Windows principale, la suppression de partitions Windows inutiles (par exemple un lecteur 'D') et leur remplacement par des partitions Linux, jusqu'au nombre de 5 et au-dessus. Notez que MS-Windows doit être au préalable complètement et correctement arrêté.mga#15791. Un autre contournement est de partitionner avec gparted à partir d'un autre système installé ou à l'aide d'un système Live.


synchronisation NTP toujours activée

À la fin de l'installation, un résumé affiche un paramètre à propos de la synchronisation NTP (cliquez sur "Fuseau horaire", puis sur Suivant).


C'est inefficace : la synchronisation NTP est actuellement activée de toute façon.

Voir Réglage de l'heure in "Problèmes de logiciels". Plus d'info sur mga#15534.

Ordinateurs avec des graphiques hybrides

Les ordinateurs avec des graphiques hybrides (par exemple Intel processeur graphique intégré NVIDIA discret, donc technologie de carte Optimus) peuvent ne pas démarrer X si le pilote pour carte Intel et le pilote pour carte Nvidia sont tous deux configurés. Nos outils ne gèrent pas encore comme faut cette situation : ils voient deux cartes pour deux écrans, et la configuration n'est donc pas correcte. La solution qui a été trouvée est d'utiliser et configurer dans un premier temps uniquement la carte graphique Intel puis continuer le processus d'installation jusqu'à son terme et redémarrer.


Remarque : certains ordinateurs permettent de désactiver l'un des deux processeurs dans le BIOS ou UEFI configuration. Cela rend la situation plus simple, puisqu'un seul GPU est ensuite vu par Mageia.

Pour optimus, plus d'infos disponibles sur https://wiki.mageia.org/en/Mageia_5_Errata-fr#NVIDIA_Optimus

Problèmes de Mise à Niveau

Système non-EFI avec grub2

Si vous avez un système non-EFI avec Grub2, il y a un risque pour que vous ne soyez pas en mesure de démarrer avec le nouveau noyau après avoir redémarré votre système mis à niveau, voir mga#11827


Toutefois, amorcer un ancien noyau fonctionnera toujours.

Mise à jour : ce problème devrait être corrigé, mais il est gardé visible dans le cas où quelqu'un le rencontrerait à nouveau. Il peut être enlevé pour la version finale si personne ne le signale sur la 5RC.


Le changement de limite des ID utilisateur du système affecte la connexion

Depuis MGA5, la limite des ID utilisateur système a changé de 500 à 1000. Ceci est en convention commune avec d'autres distributions. Bien qu'une telle distinction est en soi peu importante, nous sommes un peu contraints avec elle.
Si vos utilisateurs créés avant la mise à niveau sont dans l'intervalle 500 à 1000 ils continueront de fonctionner comme prévu et devraient toujours être affichés dans les gestionnaires de connexion graphique, etc. Toutefois, la connexion en mode privée et journalisation par utilisateur n'est plus possible pour ces utilisateurs. Si vous souhaitez voir le journal de sortie pour votre utilisateur, faire simplement en tant que root:
journalctl -b _UID=$UID
ou $UID est votre identifiant d'utilisateur.
Ce n'est actuellement pas une option de configuration à modifier, et comme tel, si vous souhaitez utiliser votre journal privé de retour, nous recommandons de faire une conversion de votre compte d'utilisateur de changer l'UID pour quelque chose > 1000 (il serait aussi logique de renuméroter votre ID de groupe aussi si vous utilisez une configuration des groupes privés qui est notre valeur par défaut).

Noms d'interfaces réseau

mga#12316 : Lors de la mise à niveau en utilisant un DVD, à l'étape "Sommaire -> Pare-feu", un mélange d'anciennes et de nouvelles interfaces réseau apparaît (par exemple eth0+enp5s0f0). Après le redémarrage, seule l'ancienne dénomination apparaît dans le système, comme avant. Voir rapport de bogue pour une explication détaillée de la cause.

Remarque : au moins un utilisateur a signalé qu'après la mise à niveau via URPMI ou l'icône "Mise à niveau" bleue dans la barre d'état, son interface eth0 a été renommée de manière permanente vers un nom en utilisant le nouveau système.

Vérifiez l'espace libre sur /boot

Lorsque /boot est sur une partition distincte (c.-à-d. pour un système crypté), il peut être assez rempli par les mises à jour du noyau automatiques. Puis pendant la mise à niveau du système, si la partition est pleine, le processus peut échouer lors de la dernière étape lorsque vous exécutez mkinitrd.


Ainsi, si votre partition est distincte, vérifiez qu'elle a au moins 40 Mo de libres.


Contournement : vous pouvez passer sur tty2 (Alt + F2) où il y a une invite de travail, nettoyez manuellement l'espace, puis lancer exactement la même commande que l'installateur dit avoir échoué, revenir à l'installateur, appuyez sur Suivant et il a fini. mga#12012


Mise à niveau Mariadb

Il y a une erreur dans le message de mise à niveau. La commande "mysql_upgrade" a besoin de mariadb en cours d’exécution, utilisez "systemctl statut mysqld"

" Si ça ne fonctionne pas, utilisez "systemctl start mysqld " puis exécutez "mysql_upgrade" (ou "mysql_upgrade -p" si vous avez déjà assigné un mot de passe root) et si vous le souhaitez "mysqld stop systemctl".

Plus d'infos sur leur site web :: https://mariadb.com/kb/en/mariadb/upgrading-from-mariadb-55-to-mariadb-100

Problèmes de logiciels

Internationalisation

  • Pour GNOME, une valeur par défaut de méthode d'entrée n'est pas définie dans la session de bureau. Vous devez la définir manuellement dans les Paramètres (mga#15793).
  • Si la langue de l'utilisateur est le chinois, le japonais ou le coréen, et que pcmanfm-qt ou LXQT sont installés, pcmanfm-qt n'affiche pas les noms de fichier et de dossier dans la vue Miniatures et vue Icône en raison de la nouvelle police CJK par défaut "Source Han". Un contournement consiste à sélectionner une autre police par défaut dans les paramètres d'apparence, ou à installer un autre ensemble de polices qui fournit les caractères CJK, par exemple google-droid-sans-fonts, fonts-ttf-chinese-opendesktop, fonts-ttf-japanese (pour le japonais uniquement), ou des fonts-ttf-korean(pour le coréen uniquement). Le paquetage fonts-otf-source-han peut être supprimé ultérieurement (mga#16043).

Spice vdagent (KVM/XEN)

Pour que spice-vdagent fonctionne, vous devrez démarrer les clients avec le paramètre de noyau "pci=nomsi". Si vous ne le faites pas, le spice guest socket ne sera pas instancié et donc spice-vdagent ne pourra pas se connecter à l'interface hôte.

Enlightenment

Enlightenment a été mis à jour en version 0.18.8.


Les outils Mageia ne démarrent pas sous E18 en raison de l'absence de l'agent polkit

Enlightenment ne veut pas démarrer des applications à partir de /etc/xdg/autostart par défaut, ce qui signifie qu'aucun agent polkit ne sera démarré. Depuis Mageia 4 tous les outils Mageia de configuration ont été transcrit vers polkit

Les utilisateurs auront besoin d'activer un agent polkit, soit via le menu => Paramètres => Tous => Applications => démarrer automatiquement des applications et permettre un agent polkit. Ou activez autostart via la ligne de commande :

echo "/etc/xdg/autostart/polkit-mate-authentication-agent-1.desktop" >> ~/.e/e/applications/startup/.order

Voir mga#13029 pour plus de détails.

KDE 4

  • L'utilisation de Onboard Accessibility Package (clavier à l'écran) dans KDE va entraîner un alongement de l'ouverture des outils d'interface graphique KDE en tant que root jusqu'à 120 secondes. Si vous utilisez régulièrement des applications d'interface graphique KDE comme root p. ex. Dolphin, Kate, kwrite, etc. et souhaitez utiliser Onboard, le retard peut être retiré par la désinstallation du paquetage qtatspi-plugin. Cela va désactiver une ou deux caractéristiques subtiles de Onboard qui passeront probablement inaperçues (mga#11975).
  • Si vous avez un ou plusieurs numéros dans votre mot de passe de connexion dans kdm, et vous utilisez normalement votre clavier numérique pour les numéros, alors il est conseillé d'installer le paquetage numlock s'il n'est pas déjà installé. Ce dernier vous assure d'avoir votre clavier numérique activé la prochaine fois que vous vous connectez à kdm (mga#15719).
  • Virtualbox ne semble pas ajouter l'utilisateur actuel au groupe vboxusers lorsqu'il est installé. Cela provoque des problèmes dans Virtualbox pour voir tout périphérique connecté via USB. Si vous ajoutez votre utilisateur à ce groupe et redémarrez l'ordinateur entièrement et ce problème disparaîtra.

Voir (mga#16881).

KDE Frameworks 5 / Plasma 5

  • Plasma 5 n'est pas l'un des environnement de bureau pris en charge dans notre programme d'installation, et n'est pas présent sur le DVD d'installation. Il peut encore être installé à partir du sources d'installation réseau, mais il n'est pas recommandé, sauf à des fins de test, à l'heure actuelle. La version actuelle est assez ancienne en raison de la période de gel prolongé pour le développement de Mageia 5 et l'intégration n'est pas aussi bonne que celle de KDE 4 à l'heure actuelle (bien que beaucoup de travail d'intégration ait déjà été fait!). Toutefois, une grosse mise à jour de cet environnement de bureau sera probablement apporté plus tard à Mageia 5 (mais ne considèrez pas cela comme une promesse! Celui qui écrit des mots n'est pas lui qui va décider et faire le travail!).
  • Le Plasma 5 ne peut pas être installé avec KDE 4. L'installation task-plasma5 demande le retrait de KDE 4.


  • Pour installer KDE Frameworks 5 / Plasma 5 :
 urpmi task-plasma5

Cela désinstallera KDE4 et installera Plasma5.

GNOME

  • Veuillez noter que la version actuelle de GNOME nécessite l'extension composite du serveur X activée. Si ce n'est pas le cas, soit à partir de pilotes X non pris en charge, ou si vous avez explicitement désactivé "translucidité" pendant l'installation ou dans le Centre de Contrôle Mageia, la session gnome échouera au moment de la connexion.
  • Certains périphériques, notamment des téléphones et caméras, utilisent le protocole MTP pour communiquer avec le PC via une connexion USB. Ces appareils ne sont pas reconnus par défaut dans Fichiers. Le paquetage gvfs-psg doit être installé séparément pour que cela fonctionne.

LXQt & RazorQt

LXQt est le successeur de razorqt. L'apparence a l'air identique, mais il ajoute bien d'autres fonctionnalités de bureau. La plupart des applications viennent de LXDE, mais en version QT.

Conserver LXDE comme bureau séparé est en discussion. Voir NOTE ci-dessous.

razorqt est devenu obsolète, et ses utilisateurs auront LXQt après une Mise à Jour vers Mageia 5 s'ils avaient razor-qt auparavant.

Pour les utilisateurs de cauldron, un retrait manuel et la réinstallation du paquetage lxmenu pourrait être nécessaire.

La gestion des versions du paquetage lxmenu-data a été corrigé, et si vous disposez de la version 0.7 ou 0.8, vous devez executer :

rpm -e --nodeps lxmenu-data; urpmi lxmenu-data

pour recevoir le paquetage lxmenu-data-0.1.4-1.mga5 corrigé. Ce n'est pas nécessaire lors de la mise à niveau depuis Mageia 4.

LXDE

  • Dans Mageia 4, nous avons utilisé le menu à partir de /etc/xdg/menus/applications.menu parce que /etc/xdg/menus/lxde-applications.menu n'était pas disponible. Donc, si le fichier ~/.config/lxsession/LXDE/desktop.conf dans la section [Environnement] contient "menu_prefix=lxde-", cela n'avait pas d'importance. Dans Mageia 5, LXQt fournit un fichier /etc/xdg/menus/lxde-applications.menu, donc, pour maintenir l'utilisation de /etc/xdg/menus/applications.menu, certaines modifications ont été faites et elles peuvent causer un problème après la mise à niveau de Mageia 4 : si aucun menu n'est disponible après s'être connecté à LXDE, ouvrez le fichier ~/.config/lxsession/LXDE/desktop.conf, dans la section [Environnement], trouver "menu_prefix=lxde-", modifiez-le en " menu_prefix=" (sans les guillemets). Après vous être déconnecté et connecté à nouveau, le menu réapparaît.
  • Si l'économiseur d'écran affiche le message GTK : "Impossible de charger le module "canberra-gtk-module", vous pouvez vous débarrasser de ce message en installant le paquet lib64canberra-gtk0 pour architecture x86_64, ou libcanberra-gtk0, pour architecture i586, mga#15176.
  • L'arrêt ou le redémarrage peut prendre plus de temps que normalement nécessaire car LXDM ne gère pas bien le signal SIGTERM envoyé par systemd, mga#15168. Une solution de contournement est d'installer un autre gestionnaire d'affichage et de l'activer via drakdm
  • Quand vous vous connectez pour la première fois à LXDE, l'économiseur d'écran peut éventuellement verrouiller l'écran immédiatement, mga#15460.
  • Si vous utilisez la connexion automatique, le clavier affiché par LXPanel est US même si c'est un autre qui est configuré, mga#14622.
  • Si vous cochez Afficher la « Corbeille » sur le bureau, dans les préférences du bureau, onglet Icônes du bureau, vous allez avoir deux icônes « Corbeille » sur le bureau, mga#14210.

Cinnamon

  • Dans une machine virtuelle, Cinnamon peut démarrer en mode sans échec si la VM n'a pas de prise en charge d'accélération 2D (mga#15991).
  • Les polices figurant sur le fond d'écran par défaut peuvent être trop sombres pour être lues facilement (mga#15843)

Mate

  • A cause de l'incompatibilité avec Bluez5, les paquetages mate-bluetooth et mate-file-manager-sendto-bluetooth ont été abandonnés et le bureau Mate ne fournit pas de support bluetooth pour l'instant. Les développeurs Mate suggèrent d'utiliser : Blueman lorsqu'il est complètement migré vers Bluez5. Le support Blueman avec bluez5 est en stade alpha, et beaucoup de fonctions ne marchent pas. Lorsque une version stable sera diffusée, elle sera fournie avec les dépôts backports. Comme contournement, les utilisateurs de Mate peuvent utiliser bluedevil pour avoir le support du bluetooth.
  • Il y a un problème avec l'appli drawer ("tiroir") du panneau. Lorsque l'appli drawer est ajoutée au panneau et que celui ci est rempli avec d'autres applets, il s'étire le long de l'écran et l'icône de drawer peut disparaître. C'est un problème connu depuis longtemps et toujours en cours d'investigation. Voir Mate Github numéro 44 et Mate Github Question 120 Pour de plus amples informations.

XFCE

Dans Mageia 5, pnmixer est utilisé par défaut, au lieu de xfce4-mixer , mélangeur par défaut de Mageia 4.

Après une mise à jour, vous pouvez vous retrouver avec deux applications de mixage. Comme elles peuvent coexister, mieux vaut décider ce qui vous convient le mieux et désactiver ou désinstaller l'autre.

Voir bogue 15784.

dkms-iscsitarget

dkms-iscsitarget est déprécié en faveur de targetcli

autofs

Pour configuer la fonctionnalité autofs "/net/hostname", passer en commentaire la line /net dans /etc/autofs/auto.master.

Cependant, la ligne actuelle /net -hosts est incorrecte.

Pour fonctionner, remplacer la ligne avec /net /etc/autofs/auto.net

Cela est lié à un bogue redhat https://bugzilla.redhat.com/show_bug.cgi?id=1038356

sddm

bogue 15357 sddm va montrer le drapeau des USA pour la disposition du clavier, mais lorsque vous tapez la première lettre il doit passer à la disposition correcte.

Grub2

Support de Drakboot

Grub2 est pris en charge par Boot de Mageia (drakboot Outil de configuration, utilisé dans les installateurs et le Centre de Contrôle Mageia) mais sa configuration n'est que partielle. Si vous avez besoin d'options plus avancées, il est recommandé d'utiliser l'une des méthodes grub2 natives décrites dans /usr/share/doc/grub2/README.Mageia. (mga#9627)

Options du noyau

comme certains modes graphiques spécials devront peut-être être ajoutés soit par l'outil drakboot dans le CCM, soit manuellement dans le fichier /etc/default/grub.
Ils peuvent être ajoutées dans cette ligne :-
GRUB_CMDLINE_LINUX_default="splash calme nokmsboot vga=792 reprendre....."
Remarque : Après avoir apporté des modifications au fichier /etc/default/grub exécutez update-grub (ou update-grub2 qui fait la même chose) et entrez le mot de passe root si demandé.

Grub2 et UEFI

Avec le système UEFI, nous allons installer Grub2 obligatoirement. Le chargeur de démarrage sera installé dans la partition de ESP (mga#16058). Il n'y a plus de référence au MBR.

Multi-amorçage (PC-BIOS)

lors de l'installation de grub2 sur une partition (pour le multi-amorçage) à l'aide de drakboot ou le programme d'installation, rien n'est écrit sur la partition boot sector comme ce n'est pas recommandé pour des raisons de fiabilité liées à l'utilisation de listes de bloques. Ces dernières sont sujettes à la réécriture par certains utilitaires de système de fichiers, et même impossibles sur certains systèmes de fichiers. Au lieu d'une copie du programme d'amorçage grub2, le noyau est écrit en tant que /boot/grub2/i386-pc/core.img et cela peut être démarré à partir de l'une ou l'autre entrée héritée de grub ou de grub2 utilisé dans un bootloader master dédié ou d'un autre système.

Une entrée appropriée dans un menu.lst hérité de grub pour amorcer Mageia à l'aide de grub2 installé sur sda7 serait :

title Mageia 5 on sda7
root (hd0,6)
kernel /boot/grub2/i386-pc/core.img

une entrée dans un /boot/grub2/grub.cfg créé manuellement (pour un bootloader master dédié) ou lors de l'ajout d'un menu généré automatiquement à l'aide de /boot/grub2/custom.cfg , l'entrée serait :

menuentry 'Mageia 5 on sda7' {
root=(hd0,msdos7)
multiboot /boot/grub2/i386-pc/core.img
}

Si /boot est sur une partition séparée (p. ex. nécessaire lorsque btrfs est utilisé pour root), une entrée appropriée (où /boot est sur sda6) serait comme ci-dessous. Notez également le chemin de démarrage multiple :

menuentry 'Mageia-5 (btrfs root)' {
root=(hd0,msdos6)
multiboot /grub2/i386-pc/core.img
}


Un avantage majeur de grub2 face à grub est la capacité d'utiliser des étiquettes de partition sans connaissance d'affectations de périphériques peu fiables. Si la partition racine Mageia est étiqueté 'mageia-4' (en supposant que n'est pas /boot sur une partition distincte) alors ceci peut être utilisé :

menuentry 'Mageia 5' {
search --no-floppy --label --set=root mageia-5
multiboot /boot/grub2/i386-pc/core.img
}

Notez que depuis la partition boot record n'est pas utilisée par Grub2, il peut être utilisé par grub legacy alors que les deux sont installés ensemble, ce qui permet de chaîner dans grub multibooting legacy et dans grub2 de deux entrées de menu principale séparée.

Installation minimale

Lorsqu'une installation minimale de grub2 est nécessaire, il peut être installé avec urpmi grub2 --no-recommends qui va ignorer os-prober et grub2-mageia-theme, donnant un menu grub2 classique (texte seulement) avec aucun autre système répertorié. os-prober peut être installé ultérieurement comme peut l'être le paquetage de thème Grub2 - simplement les installer ou désinstaller à volonté, lancer update-grub dans un terminal, et l'effet sera visible au démarrage suivant.

Menu KDE Quitter

pour utiliser KDE options sur la laisser > Redémarrer sous-menu (accessibles en cliquant sur l'icône jaune - pas le texte) avec grub2, il est nécessaire de modifier le fichier /etc/default/grub à inclure :

grub_DEFAULT=enregistré

Exécutez update-grub après édition de /etc/default/grub

Il faut également sélectionner Grub2 dans Configuration du Système > Administration du système > Écran de connexion > onglet Arrêter > Gestionnaire de démarrage.

Pour cela, KDM doit être sélectionné comme gestionnaire de connexion, cela peut être fait en le sélectionnant dans drakdm dans le Centre de Contrôle Mageia

LibreOffice

En raison d'un bug en amont, LibreOffice Calc 4.4.0.3 ne semble pas enregistrer les images mises en embases de tableur (mga#15234). Résolu par la mise à jour en version actuelle 4.4.7.

Evolution

* A cause de dépendences manquantes lors de l'installation d'Evolution, les comptes qui requirent SSL/TLS ne peuvent pas être configurés : Evolution ne demande pas de mot de passe mga#15971. Pour corriger cela, attendez une mise à jour qui incluera la dépendence, ou installez manuellement : lib64glib-networking (machine 64 bits) ou libglib-networking (machine 32 bits). Résolu par une mise à jour.

Roundcubemail

Le nouveau php-5.6 ne laisse pas Roundcubemail trouver les certificats et en conséquence la vérification de l'utilisateur à la connexion échoue. Pour résoudre ce problème, vous devez éditer le fichier /etc/php.ini et ajouter cette ligne dans la section [openssl] :

openssl.cafile=/etc/pki/tls/certs/cyrus-imapd.pem

invités Mageia sous KVM

Importés de l'Errata Mageia 4.

  • mga#14607 - Utiliser un modèle de carte vidéo QXL pour une machine virtuelle KVM peut causer un plantage lors de la commutation des terminaux virtuels pour un invité Mageia. Une solution de contournement consiste à désactiver le Kernel Mode Setting (KMS) dans l'invité en passant le paramètre modeset=0 au module de noyau qxl. Ceci peut être réalisé en tapant (en tant que root) :


echo 'options qxl modeset=0' >> /etc/modprobe.d/qxl-no-km.conf


Et puis re-créer l'initrd avec dracut (encore une fois en tant que root) :


dracut --force


Après un redémarrage, le client doit être en mesure de changer de terminaux virtuels sans planter.

Echec de Drakfirewall à l'ouverture de ports mountd pour NFS

Lors de la configuration du pare-feu avec drakefirewall et en vérifiant "NFS" pour ouvrir les ports NFS, il peut échouer à ouvrir le bon port (il semble que cela ouvre le port par défaut 4003 à la place)(mga#14550). Résolu par la mise à jour de drakx-net en version 2.24.2.

Réglage de l'heure

Parce que la synchronisation d'horloge est active par défaut (voir la synchronisation NTP toujours activée dans "Problèmes d'Installation"), réglez le temps est impossible tant dans le Centre de Contrôle Mageia et dans KDE la date et l'heure de configuration.

Une solution de contournement consiste à le désactiver avec la commande (authentification root nécessaire) :

timedatectl set-ntp false

Par la suite, le CCM et les fonctions de configuration de KDE seront en mesure de régler l'heure et la date de nouveau.

Veuillez noter qu'il peut y avoir un certain retard jusqu'à ce que les horloges du tableau de bord soient mises à jour -- la nouvelle heure peut être vérifiée immédiatement avec "date" ou "timedatectl". En outre, fixer une date ultérieure peut verrouiller l'écran si l'écran de veille est activé.

Info additionnelle à [15534 http://bugs.mageia.org/show_bug.cgi?id=15534 mga#].

bacula, dépendance manquante sur /usr/sbin/bacula-checkconf

Il manque actuellement une dépendance de bacula-fd sur bacula-dir pour /usr/sbin/bacula-checkconf et donc le début de l'bacual-fd service échoueront.

Ceci a été découvert durant la "release freeze" (gèle de version), et un correctif a déjà été engagé pour SVN, mais jusqu'à ce qu'une mise à jour soit publié, le contournement est d'installer manuellement bacula-dir.

Pour plus de détails voir mga#16022

PulseAudio

Problèmes d'utilisation du module PulseAudio dbus-protocol

Lorsque d'autres modules pulseaudio ou d'autres applications essaient d'utiliser pulseaudio dbus-module, ils vont sortir en erreur en disant que le module dbus n'est pas chargé, même lorsque c'est le cas.


Il n'y a actuellement aucune solution connue, mais notre mainteneur de pulseaudio est sensibilisé au problème.

Pour plus de détails voir mga#14709.


Lightdm n'a aucune image d'arrière-plan au premier démarrage, seulement du gris - XFCE & MATE

Le fond est OK après le premier login.

Info additionnelle dans mga#15722.

Résolu par la mise à jour lightdm-gtk-greeter-2.0.1-1.mga5.

X via startx quitte vers un écran noir (sur certaines configurations matérielles)

Après le démarrage de X à l'aide de la commande startx, il sort dans un écran noir avec l'adaptateur NV11 des cartes graphiques NVIDIA et éventuellement sur d'autres configurations matérielles.


Infos additionnelles sur mga#15662.


Installation de logiciels supplémentaires à partir d'une clé USB

Si vous avez copié un des installateurs ISOs classique sur une clé mémoire USB (soit en utilisant l'utilitaire isodumper ou en utilisant la commande 'dd') et l'avez utilisé pour effectuer votre installation initiale, le programme d'installation reconnaît la clé mémoire comme un lecteur de CD/DVD et ajoute automatiquement 'CD-ROM' dans la liste des supports utilisés par les outils d'installation du logiciel Mageia (l'interface utilisateur graphique, ou de la commande rpmdrake, urpmi).


Si vous utilisez ensuite la commande urpmi pour installer des logiciels supplémentaires alors de la clé USB n'est pas branché, il vous invite à insérer le support, puis sort un message d'erreur :


Utilisation de valeur non initialisée dans sous-routine entrée dans /usr/lib/perl5/Vendor_perl/5.20.1/x86_64-linux-thread-multi/net/DBus/contraignant/Connection.ligne pm 257


Ce message d'erreur semble être fallacieux et peut être ignoré. Toutefois, urpmi puis attend que vous insériez un CD/DVD, et ne reconnaît pas votre clé USB comme un substitut acceptable.


Les 3 solutions de contournement sont :

  • Insérer la clé USB avant d'exécuter la commande urpmi
  • Désinstaller le paquetage 'perl-Hal-Cdroms' (ce qui entraîne urpmi à vous demander d'appuyez sur Entrée lorsque vous avez inséré les supports, plutôt que d'essayer de le détecter automatiquement)
  • Désactiver ou supprimer les entrées 'cdrom' dans la liste des supports utilisés par urpmi (Seulement applicable si vous avez ajouté des référentiels en ligne à la liste des médias, et que vous ne voulez pas installer les paquetages à partir de la clé USB)

Notez que l'interface graphique du programme d'installatio, rpmdrake, n'est pas affecté par ce bug.


Notez également que si vous installez via un démarrage UEFI, la clé USB est uniquement reconnue comme un CD/DVD si vous sélectionnez l'option par défaut "Installer à partir d'un DVD'.


Infos additionnelles sur mga#16142.

Problèmes Matériels

Gels aléatoires et problèmes de réseau local sans fil Intel sur les systèmes BayTrail

Les systèmes Intel Baytrail ont un bogue matériel qui est connu à partir des versions de noyau supérieures à 4.1 et qui entraîne certains problèmes (voir kernelbug#109051). Jusqu'à ce qu'une solution définitive soit implémentée, il est suggéré d'ajouter l'option "intel_idle.max_cstate=1". Pour l'ajout d'options de compilation voir les instructions ici (How to set up kernel options). Il a également été signalé que l'ajout de l'option du noyau peut résoudre des problèmes de réseau local sans fil dans les systèmes BayTrail.

Informations supplémentaires mga#18881 et mga#18843.


X pourrait ne pas démarrer avec les cartes graphiques Nvidia avec le pilote nvidia340 pilote (GeForce 8100 à GeForce 415)

Après une mise à niveau vers Mageia 5 ou également après une installation, au cours du premier amorçage, le serveur X peut échouer dans le démarrage, si vous utilisez le pilote nvidia340 (pour les cartes graphiques NVIDIA GeForce 8100 à GeForce415)

Pour résoudre ce problème, soit vous pouvez passer au niveau d'exécution 3 (runlevel 3) à l'aide de init 3 en tant que root

ou ajouter 3 pour les options d'amorçage lors du démarrage. Voir Comment_ajouter_des_options_au_noyau-fr pour plus de détails sur la façon de le faire.

Après vous être connecté en tant qu'utilisateur root, exécutez drakx11 et sélectionnez à nouveau le pilote NVIDIA, il devrait alors être téléchargé et installé. Après un redémarrage, votre session X devrait commencer comme d'habitude.

Voir aussi (en) : https://forums.mageia.org/en/viewtopic.php?f=7&t=9885 and https://forums.mageia.org/en/viewtopic.php?f=23&t=10019

X pourrait ne pas démarrer sur les systèmes basés sur Intel "Skylake"

Voir aussi mga#17174 pour plus de détails. Après une installation réussie de Mageia 5, le serveur X peut ne pas démarrer si votre système possède un processeur Intel "Skylake".
Pour utiliser le processeur graphique Intel HD intégré, vous devez installer les mises à jour y-compris le nouveau noyau 4.1.x, pendant ou après l'installation avant de pouvoir utiliser le serveur X avec le processeur graphique Intel HD intégré.
Voir nos avis de mise à jour MGASA-2015-0386 et MGASA-2015-0435 pour plus de détails sur les mises à jour du noyau.

En outre, la prise en charge expérimentale du pilote i915 doit être activée. Cette option n'est pas activée dans les noyaux livrés avec Mageia 5, mais sera probablement activé par défaut dans l'une des prochaines mises à jour du noyau.

Une manière d'ajouter cette prise en charge est d'ajouter la ligne suivante dans le fichier grub les options du noyau :

i915.preliminary_hw_support=1

Voir Comment ajouter des options au noyau pour plus de détails sur la façon de le faire.

Remarque! A partir du noyau 4.1.15-1.mga5 publié dans la mise à jour : MGASA-2016-0005, la prise en charge i915.preliminary_hw_support est activée par défaut.

La prise en charge complète de Skylake ne sera possible qu'avec le noyau >= 4.3.

Pas de réseau filaire ou sans fil sur les systèmes Intel "Skylake"

Si vous faites une installation standard et que vous avez un système avec des interfaces réseau Skylake, ceux-ci ne fonctionneront pas. Il peut être nécessaire de mettre à niveau le noyau égaement pour la partie graphique Skylake i915.

Ceci est le cas par exemple sur les sytèmes Intel NUC le plus récents (des essais ont été faits avec un NUC6i3SYH i3-6100U, mais tous les SYH et SYK doivent avoir les mêmes puces).

Voud devez télécharger des paquetages depuis un autre système sur une clé USB (vous pouvez agrandir la partition FAT32 des images hybrides pour les y inclure).

A cette heure (février 2016), j'ai eu besoin de ces paquetages, en architecture 64bits et noyau de saveur "desktop" :

  • kernel-desktop-4.1.15-2.mga5-1-1¹
  • kernel-firmware-20150722-1.mga5
  • kernel-firmware-nonfree-20151018-1.mga5

Le premier et le second proviennent des dépôts "Core Updates", le dernier du dépôt "Nonfree Updates".

Après l'installation et avant de redémarrer, vous aurez besoin de les installer

¹Vous devez vérifier si l'installeur choisi la saveur "desktop" ou la saveur "server".

NVIDIA Optimus

Tout d'abord, voir la partie sur les cartes graphiques hybrides dans les sections Installation et LiveDVDs.

Pour les propriétaires d'ordinateurs qui utilisent Optimus, nous regrettons qu'il ne soit pas géré en "sortie de boîte", mais vous pouvez le faire fonctionner dans la plupart des cas. Voici les étapes qui ont fonctionné pour la plupart des testeurs, elles ne sont pas si dures finalement parce que nous avons travaillé dessus du mieux que nous pouvions :


  • Configurer uniquement la carte graphique Intel, ou vesa/fbdev si votre chipset n'est pas bien prise en charge.
  • Installer le paquet de bumblebee. Il va vous demander de choisir entre bumblebee-nouveau (pilote libre) et bumblebee-nvidia (pilote non-libre, si vous avez activé le dépôt nonfree).
  • Si vous avez besoin d'utiliser le GPU NVIDIA, démarrez votre application avec


primusrun nom_de_l_application


Ou


optirun nom_de_l_application


Certaines personnes aiment désactiver vsync. La personne qui a écrit cette note ne sais pas si cela améliore vraiment les performances ou pas, il suffit de l'essayer, et si vous avez une mauvaise performance, essayer :


Vblank_mode=0 primusrun nom_du_application


bug connu depuis le Noyau 3.19, le pilote NVIDIA, une fois chargé, n'est plus déchargé lorsque des applications qui l'utilisent s'arrêtent. (mga#16094). Ce qui signifie que la carte séparée reste alimentée. Il y a un moyen de le désactiver manuellement, heureusement. En tant que root :


rmmod nvidia && tee <<<OFF /proc/acpi/bbswitch

Corruption de l'affichage une fois que le curseur se déplace

Avec certains matériels et seulement avec les ISO 64 bits, l'affichage du programme d'installation est parfois corrompu là où le curseur de la souris est déplacé. Solution de contournement : sélectionnez une autre résolution sur la ligne du noyau, par exemple avec vga=787 (15bpp) au lieu de vga=788.

la gouvernance par défaut de cpufreq est la performance, certains utilisateurs d'AMD ou d'Intel plus anciens pourrait avoir besoin de passer au mode "à la demande" (ondemand)

Voir aussi les bogues mga#13368, mga#14584, et mga#9801

La valeur de gouvernance par défaut de cpufreq a été établie sur les performances par le biais de /etc/sysconfig/cpupower, car les processeurs Intel actuels prennent en charge seulement les modes performance ou économe (powersave).

Avec la gouvernance par défaut précédente (ondemand), le service cpufreq échouerait pendant l'amorçage.


Les utilisateurs qui ont un CPU AMD et Intel avant 2009 environ peuvent avoir besoin de passer au mode "ondemand", faute de quoi leur CPU fonctionnera à pleine vitesse

et donc à température maximum tout le temps. La gouvernance peut être facilement modifiée pendant l'execution en root via

cpupower frequency-set -g ondemand

et la fréquence en cours et le mode actuel de gouvernance peut être interrogé via

cpupower frequency-info

Pour rendre la modification permanente, vous avez encore besoin de modifier le fichier /etc/sysconfig/cpupower et de remplacer les "performance" par "ondemand".

Les pilotes propriétaires sont connus pour être problématiques avec nouveau Xorg

Exemple: fglrx pour AMD/ATI Radeon. Le contournement est d'utiliser le pilote xorg ati ou vesa.

Echec d'amorçage possibles à partir d'un DVD avec certains matériels Radeon

Dans certaines situations obscures, le démarrage depuis le DVD peut s'arrêter avec le message "gdm-Xorg-:0[1519]: (EE) AIGLX error: dlopen of /usr/lib64/dri/r600_dri.so failed (/usr/lib64/dri/r600_dri.so: undefined symbol: _glapi_tls_Dispatch)". La solution pour l'instant est de démarrer l'ISO à partir d'USB.


l'écran tactile n'est pas reconnu comme un périphérique touchsceen, mais se comporte comme une souris normale

Dans ce cas, vous pouvez essayer d'installer x11-driver-input-libinput et de redémarrer le système. (mga#18854 )

tablette Wacom Bamboo CTH-301 / K" ne fonctionne pas

Le noyau n'est pas prêt à la gérer. Nous devons peut-être attendre jusqu'à ce que le noyau 4.1 soit sorti pour le gérer (mga#15459).

OpenGL 2.0 incompatible avec le matériel plus ancien sous Nouveau et KDE

Certaines cartes vidéo plus âgées, même si annoncée comme compatible OpenGL 2.0, peuvent nécessiter un réglage d'OpenGL 1.2 inférieur dans les réglages de KDE: Configuration du Système / Effets de bureau / Options Avancées / Mode d'Affichage composé.


Si l'écran est illisible sur KDE, essayez de désactiver les effets avec Alt Maj F12 et ajuster le réglage ci-dessus. Les effets du bureau peuvent être activés de nouveau avec ce même raccourci.


Plus d'infos sur mga#15462 et http://userbase.kde.org/Desktop_Effects_Performance (voir la section "OpenGL version").


Certains scanners ne fonctionnent pas avec KDE et usblp chargé

Le fonctionnement de certains scanners, comme le Canon PIXMA MP250, peut échouer si le module usblp est chargé. Une solution de contournement consiste à exécuter "rmmod usblp" en tant que root, ou à ajouter 'backlist usblp' à /etc/modprobe.conf, pour l'empêcher de charger à chaque amorçage.

le firmware EFI de certains fournisseurs est forcé à utiliser MS Windows par défaut

Voir mga#19112,commentaire 9


Certains ordinateurs Medion, HP et Lenovo ont figés dans leur firmware EFI d'utiliser Windows par défaut, efibootmgr ne peut pas changer cela.